Home | 簡體中文 | 繁體中文 | 雜文 | Search | ITEYE 博客 | OSChina 博客 | Facebook | Linkedin | Email

5.14. pthreads

編譯PHP時需要加入 --enable-maintainer-zts 選項才能安裝pthreads

# pecl install pthread
		

配置檔案

		
cat > /srv/php-5.5.7/etc/conf.d/pthreads.ini <<EOF
extension=pthreads.so
EOF
		
		
$ php -m |grep pthreads
pthreads
		

5.14.1. pecl/pthreads requires PHP (version >= 7.0.0RC5), installed version is 5.6.16

pthreads 3.0.0 之後不再支持5.6.x,PHP 版本大於等於 7.0.0

			
# pecl install pthreads
pecl/pthreads requires PHP (version >= 7.0.0RC5), installed version is 5.6.16
No valid packages found
install failed
			
			

解決方法是安裝較低版本的pthreads-2.0.10

# pecl install pthreads-2.0.10
			
comments powered by Disqus